APT-GET ERROR SLOVED

I recently installed Kali Linux Rolling as main Operating System and ran into a problem. When i try to use apt-get update an error code returned !

An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive-10.kali.org/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>

How we fix this problem ? Finally I found 2 solutions that helped fix this problem !

First method :

wget https://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2018.1_all.deb
apt install ./kali-archive-keyring_2018.1_all.deb
apt-get update

Second method :

wget -q -O - archive.kali.org/archive-key.asc | apt-key add
apt-get update

That’s it. I hope this will help you!